Troubleshooting Guide for "Problem while Fetching VM Information Using WMI Repositories" in BDRSuite

Troubleshooting Guide for "Problem while Fetching VM Information Using WMI Repositories" in BDRSuite

KB ID: 115095
Issue:
Encountering the error "Problem while fetching VM information using WMI repositories" during VM information retrieval.
Cause:
The error may arise due to the following reasons:
1. The target host is not reachable.
2. There is an issue accessing Windows Management Instrumentation (WMI) on the target host.
3. The provided target host credentials have changed but are not updated in BDRSuite Backup Server or BDRSuite client.
4. If the added target host is Hyper-V, ensure Hypervisor is available on the target machine.
5. The BDR or VMBackup client service logon account is set to "local system account" instead of an administrator user.
Solution:
Cause 1: When the Added Target Host Is Not Reachable
The error "Problem while fetching VM information using WMI repositories" may occur due to the target host being unreachable. Follow the steps below to troubleshoot:
1. Confirm UNC Validation:
  1. Manually verify admin$ share access from the machine where "BDRSuite" is installed.
  2. Test admin$ access:
  1. Go to 'Run' and type `\\IP\admin$` (Replace IP with the Hostname/IP of the target machine).
  2. Example: `\\192.168.100.100\admin$`
  1. If there's no network connectivity issue, UNC validation is successful.
2. Troubleshooting Network Connectivity Issues:
Case 1: Ensure the firewall does not block remote connections. Add the "Remote Service Management" rule to Inbound firewall rules.
  1. Step 1: Open Control Panel.
  2. Step 2: Navigate to System and Security > Windows Firewall > Advanced Setting.
  3. Step 3: In Windows Firewall with Advanced Security, click Inbound rules.
  4. Step 4: Click New Rule and opt for the Predefined option.
  5. Step 5: In the predefined drop-down, select "Remote Service Management" rule, enable it, and click Finish.
Case 2: Ensure the following services are running on your target machine:
  1. Server Service.
  2. Windows Remote Management (WS-management).
Cause 2: When There Is an Issue in Accessing Windows Management Instrumentation (WMI) of Your Target Host
1. Ensure the firewall doesn't block any WMI function. Add the "Windows Management Instrumentation" rule to Inbound firewall rules.
  1. Step 1: Open Control Panel.
  2. Step 2: Navigate to System and Security > Windows Firewall > Advanced Setting.
  3. Step 3: In Windows Firewall with Advanced Security, click Inbound rules.
  4. Step 4: Click New Rule and opt for the Predefined option.
  5. Step 5: In the predefined drop-down, select "Windows Management Instrumentation" rule, enable it, and click Finish.
2. Ensure the "Window Management Instrumentation" service is running on your target machine.
Cause 3: When the Provided Target Host Credentials Have Been Changed
Update the new credentials of the target in your Vembu BDR/VMBackup client:
1. Open the Vembu BDR/VMBackup console.
2. Navigate to Backup > Manage Servers.
3. In Manage Server, select the respective target host and click on the EDIT option.
4. Add new credentials with a new description and save.
5. Alternatively, edit the existing host password directly by navigating to Management > Credential manager and proceed to edit.
Cause 4: When BDR or VMBackup Client Service Logon Account Is in "Local System Account" Instead of Administrator User
Ensure BDRSuite Backup server or BDRSuite Client services are running with either of the following privileges:
  1. Administrator.
  2. User having administrator privilege.
Steps to add/verify Service logon on your Server/Client machine:
1. Go to 'Run' and type “Services.msc.”
2. Check for BDRSuite service from where VIS push is about to take place.
3. Right-click the service, go to properties, and navigate to “Logon.”
4. Provide your user details in the “This Account” column.
Example: If your user is “Administrator” with the password "Test123$":
  1. This account = .\Administrator.
  2. Password = Test123$.
  3. Confirm Password = Test123$.
5. Once user account details are updated, apply the changes and restart the respective service.
Note: In case you face any issue during service restart, then please recheck the user credentials provided during logon update.

Confirmation Test:
Perform a pre-test using WBEM utility after verifying the above solutions:
1. Open “wbemtest” on your server/client machine.
2. In the namespace text box, provide Target hostname/IP: `\\IP\root\cimv2` (e.g., `\\192.168.100.100\root\cimv2`).
3. Provide the username and password and click on connect.
Note: If the target machine is local, do not provide a username and password.
4. In case of error, recheck the solutions and wait until the WBEM test becomes successful.
5. Once successful, proceed to add the desired Host.