Backup Failure: Invalid Guest VM Credentials for Application-Aware Backups

Backup Failure: Invalid Guest VM Credentials for Application-Aware Backups

KB ID: 104059
Problem:
When attempting to perform an application-aware backup, users may encounter a backup failure with the alert "Backup failed while processing Application-aware due to invalid guest VM credentials."
Cause 1:
This alert is triggered when the credentials provided for the guest machine(s) are incorrect.
Solution:
To resolve this issue, verify whether the credentials provided for the guest machine(s) are correct. You can confirm the given credentials by navigating to the Edit Backup page.
Cause 2:
For application-aware enabled backups, Backup Agent attempts to push an appaware-guest-tool into the guest machine to ensure application consistency. By default, the tool uses the installation location as "C:\Windows". If the provided user account does not have sufficient permissions to create a folder in the location "C:\Windows" on the Guest Machine, the backup will fail with the given error.
Solution:
To address this, it is necessary to provide an administrator account for the appaware process during the backup configuration. If not, edit the backup job and provide the administrator account credentials.
Additionally, ensure that the given user account has privileges (without elevated permissions) to create a folder inside "C:\Windows" on the guest machine.
Cause 3:
This can occur due to the following reasons:
A) The added target host is not reachable (UNC validation path validation [admin$]).
B) There is an issue in accessing Windows Management Instrumentation (WMI) of the target host.
C) The guest machine's Windows Firewall is enabled, requiring the addition of a Windows Firewall exception in Group Policy Object Editor.
Solution:
Follow the steps below to address each cause:
For Cause A:
1. Verify UNC validation by manually accessing the admin$ share on the target machine.
2. Check if the target host is reachable. If reachable and the error persists, proceed with the following verifications:
   Case 1: Ensure that your firewall does not block remote connections and add the "Remote Service Management" rule to the Inbound firewall rules in the target machine.
   Case 2: Ensure that the Server Service and Windows Remote Management (WS-management) are running in the target machine.
For Cause B:
1. Ensure that your firewall does not block any Windows Management Instrumentation function and add the "Windows Management Instrumentation" rule to the Inbound firewall rules in the target machine.
2. Ensure that the Windows Management Instrumentation service is running on the target machine.
For Cause C:
Configure the Windows Firewall service to allow inbound remote administration connections using the Group Policy Object Editor.
Cause 4:
For application-aware enabled backups, if the given user account does not have enough permission to create a folder in the location "C:\Windows" on the Guest Machine, the backup will fail with the given error.
Solution:
1. Change the BDRSuiteIntegration service logon user to an admin user in services.msc (By default, BIS service runs in the local system account).
2. Restart the BDRSuiteIntegrationService once the logon user is changed.
3. Retry triggering the backup.
If the issue persists after following these solutions, please contact BDRSuite Support for further assistance.