KB ID : 104015
Products :
Published : Dec. 12, 2019
Created : Dec. 12, 2019
Last Modified : Dec. 12, 2019

Cause:

1) The Hyper-V Virtual Machine Management Service is not running/enabled in the owner node machine.

2) The VM configured for backup may not be in the VM list, as the command would have failed in one of the nodes.

Solution:

For Cause 1: Make sure if the Hyper-V Virtual Machine Management Service is running by following the steps below:

  • Go to services.msc in the Hyper-V host machine
  • Search for the Hyper-V Virtual Machine Management Service and find the status of the service
  • If the service is stopped or disabled, start the service and continue with the backup

For Cause 2: When there is an issue in accessing Windows Management Instrumentation [ WMI ] of your target host.

Case 1: Make sure your firewall does not block any Windows Management Instrumentation function. Add the below rule into your Inbound firewall rules in your target machine to ensure the same

Step 1: Open control panel

Step 2: Navigate to System and Security >Windows Firewall >Advanced Setting

Step 3: In Windows firewall with advanced security, click Inbound rules

Step 4: Inbound rules > click new rule and proceed to opt for Predefined option

Step 5: In predefined drop-down > select ‘Windows Management Instrumentation’ rule and proceed with the default option to enable it and click finish

Case 2: Make sure Following services are running in your target machine

Windows Management Instrumentation

Case 3: If you are using NAT, please make sure WMI port is allowed in NAT firewall

WMI port can be static or dynamic, by default WMI port is dynamic.

I. If your WMI is running in static port, then directly add the WMI port into NAT firewall.

II. If your WMI is running in dynamic port, add the WMI port range into your NAT firewall. The range is from 1024 to 65535.

If it is not feasible, then convert WMI port into static port and add that static port into firewall setting of NAT.

Steps to convert the WMI port from dynamic to static:

Set the DCOM config to use a static port

Step 1: Open Run and type ‘dcomcnfg’

Step 2: Navigate the tree to My Computer → DCOM Config → Windows Management and Instrumentation, select properties of that folder

Step 3: Select the Endpoint tab under Windows Management and Instrumentation properties

Step 4: Select the Properties button for Connection-oriented TCP/IP

Step 5: Use static endpoint, set the port

Configure WMI to use a fixed port

Follow these steps from below link to change WMI port to fixed:

Confirmation test:

When the above mentioned solutions are verified, perform a pre-test using WBEM utility.

Step 1: Open “wbemtest” in your server/client machine

Step 2: In the namespace text box provide Target hostname\IP : \IP\root\cimv2

Example: \192.168.100.100\root\cimv2

Step 3: Provide the username and password and click on connect

Note: If the target machine you are trying to push to is a local machine, do not provide any username and password, just proceed to connect

Step 4: If you face any issues, recheck the solution and wait until the wbem test becomes successful

Once successful, proceed to add the desired host.

edit retag flag offensive close merge delete