KB ID : 103005
Products :
Published : March 30, 2016
Created : March 30, 2016
Last Modified : Feb. 21, 2020

Details

Vembu uses its proprietary image backup driver to track block-level changes in the disk configured for the backup. ‘Backup failed as the source disk order is altered’ error will come if the Vembu proprietary driver is not able to track block-level changes as the order of the disks configured for the backup is changed when taking incremental backups.

Causes

The possible reasons for this error are;

1) The order of the disks in the target machine configured for the backup is changed when taking an incremental backup.

2) The external storage device(s) attached to the target machine when configuring the backup is disconnected or removed.

Solutions

In both cases, you need to change the disk order back to its original state. You can find the original order of the disk in the log of the Vembu Image Backup client/ Vembu Integration Service on the target machine.

If the backup job is configured from the Vembu BDR Backup Server, follow the below steps to find the original disk order

Step 1: Open the target machine and navigate to the Vembu Integration Service installation location. By default, the Vembu Integration Service is installed on the OS drive(C-drive in most machines)

Step 2: Open proxy.log file.

You can find the proxy.log file at <installation location="">\Program Files\Vembu\VembuIntegrationService\log\<backup server="" id="">\<backup job="" name="">\proxy.log.

For example, C:\Program Files\Vembu\VembuIntegrationService\log\VembuBDR01\ImageBackupo1\proxy.log.

Step 3: Search for Configured Disk No :: X, Current Disk No :: Y.

X - Disk number received during the initial full backup schedule Y - Disk number received for recent incremental schedule

Step 4: Change the disk order of the target machine to its original state and run the backup job

If the backup job is configured from using Vembu Image Backup Client, follow the below steps to find the original disk order

Step 1: Open the target machine and navigate to the Vembu Image Backup Client installation location. By default, the Vembu Image Backup Client is installed on the OS drive (C-drive in most machines)

Step 2: Open backup.log file.

You can find the backup.log file at <installation location="">\Program Files\Vembu\VembuImageBackup\log\<backup job="" name="">\backup.log.

For example, C:\Program Files\Vembu\VembuImageBackup\log\ImageBackupo1\backup.log.

Step 3: Search for Configured Disk No :: X, Current Disk No :: Y.

X - Disk number received during the initial full backup schedule Y - Disk number received for recent incremental schedule

Step 4: Change the disk order of the target machine to its original state and run the backup job

If the issue persists, kindly reach our support team at vembu-support@vembu.com

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