Revision history [back]

AD object restore with , in CN

I am evaluating Vembu for AD backup and restore. I am currently working in an old AD forest we still have in place that is not in production. The backup process was easy and worked fine. The restore process was simple as well but I ran into an issue. We have quite a few user accounts where the CN has a comma in it. Specifically "Lastname, FirstName" the DN of the objects will start with cn=lastname/, Firstname,...

I deleted an OU with users in it, waited replication (only 2 DCs), Opened Vembu Active Directory GLR connected to the mounted disk and open the NTDS database. When I restore the OU it does not restore any of the User objects with the , in the CN. I can restore them individually but it truncates the CN to only Lastname.

In our production AD there are quite a few of these as well since the move to creating users as Lastname, Firstname. This may not be something that will prevent our usage if Vembu but would be nice to find a solution.

Copyright © Vembu Technologies 2021. All Rights Reserved.