0

Cannot add Hyper-v Host

asked 2017-05-02 05:23:01 -0500

Zine gravatar image

Hello,

I've installed Vembu Bkp on Hyper-V VM and when I want to add a standalone Windows 2012R2 Datacenter Hyper-v host, I get this error message: "Hyper-V Backup is not supported for this version of Windows server"

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2017-05-02 07:04:59 -0500

Senthil gravatar image

updated 2017-05-08 01:39:52 -0500

Hi,

To add Hyper-V host below things are need to be considered.

  1. Need to add the Hyper-V host with administrator credentials. If it is under any Domain Controller, please add the Hyper-V Host with domain administrator credentials

  2. Hyper-V host that you are trying to add shouldn't be a virtual machine.

  3. If the machine name or username that you are trying to add has (-) in it , adding host may fail. So try giving ip address for the host.

To analyse the issue, please provide the output for the following command.

Step 1 : Open the command prompt with the administrator privilege in the VembuBDR Backup server.

Step 2 : Execute the following command and provide us the output.

  • If the Hyper-V host [Windows 2012R2 Datacenter] to be added is local machine run the following command

    Powershell wmic os get caption

  • If the Hyper-V host [Windows 2012R2 Datacenter] to be added is Remote machine run the following command.

    Powershell wmic /node:"<HostName>" /user:"<UserName>" /password:"<Password>" os get caption

    Example: Powershell wmic /node:"MachineM1" /user:"Domain2012\administrator" /password:"Apple" os get caption

Step 3: Revert back to us with the output of the above command.

edit flag offensive delete link more

Comments

If your server has a - (dash in it) the PS command and the adding of the host wont work, you have to use the IP address.

DannyH ( 2017-05-07 22:19:01 -0500 )edit

Yes, we have noticed this case and the fix will be available in our upcoming v3.8 release which is expected to be available in end of June

Senthil ( 2017-05-08 01:34:05 -0500 )edit

I have the same issue with a Standalone Host Windows 2008 server R2.

hkatergarakis ( 2017-07-17 04:00:37 -0500 )edit

As mentioned in above comment, if you have hyphen(-) in your machine name adding the Hyper-V host may fail. This is a known issue in the VembuBDR V3.7. We have fixed this issue in our v3.8 release which is expected to be released by the end of this month. So as of now if the machine name has hyphen character, try giving ip address of the Hyper-V host. If you still face the issue, kindly run the powershell command mentioned in the above thread and send us the result.

Senthil ( 2017-07-17 06:01:25 -0500 )edit

The Machine name is HYPER-V2 and as per your recommendation I used the IP address. The Hyper-V host is not part of a domain. the result of the "Powershell wmic os get caption" command is "Caption" <enter> "Microsoft Windows Server 2008 R2 Standard".

hkatergarakis ( 2017-07-17 07:55:17 -0500 )edit

The powershell command correctly results the OS Name of the Hyper-V host. So by adding the host with ip should work. But in your case it fails. In order to know the exact issue kindly contact vembu-support AT vembu.com with the VembuBDR log file which will be available in the installation location (<vembubdr installation="" location="">\logs\server.log) to assist you further.

Senthil ( 2017-07-17 09:56:13 -0500 )edit
Login/Register to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2017-05-02 05:23:01 -0500

Seen: 302 times

Last updated: May 08

Copyright © Vembu Technologies 2017. All Rights Reserved.