0

Next schedule backup - 1st Jan 1970 05:30:00

asked 2017-04-28 07:17:19 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Facing weird issue on one of the client.

When I see client reports from BDR, next scheduled time is displayed as 1st Jan 1970 05:30:00

has anyone seen this before? Will backup for that client be impacted? How to fix this?

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2017-05-02 07:36:53 -0500

Jose gravatar image

updated 2017-05-02 07:44:27 -0500

Udhaya gravatar image

Hi,

Normally, this incorrect next schedule time issue will be fixed once after editing the backup schedule. Since this issue is not resolved after editing the backup schedule, we provide you the manual steps to update Next Scheudle Time value in database.

Please follow the below instructions

1) Stop the VembuNetworkBackup Application running in the Client machine.

2) Now, open the command prompt (administrator command prompt) and go to the "<vembu_home>" location [By default, it will be 'C:\Program Files\Vembu\VembuNetworkBackup' ] and execute this command "lib\sqlite\sqlite3.exe data\sgclient.db " to open the database.

(here we assume, you have not changed the dbstorage location path and db files are present under <vembu_home>\data folder)

3) Execute the below query in database in order

i) To Get the Backup Config ID Select BACKUPCONFIGID from BACKUPCONFIG where BACKUPNAME=<backup_name>;

ii) To Update the current time as Next schedule time
update BACKUPSCHEDULES set NEXTSCHEDULETIME=(SELECT strftime('%s', 'now')) where BACKUPCONFIG_ID= <backup_config_id>;

iii) To confirm that current time is updated, please execute the below query select datetime(NEXTSCHEDULETIME, 'unixepoch', 'localtime') from BACKUPSCHEDULES WHERE BACKUPCONFIG_ID =<backup_config_id>;

4) Execute '.q' to close the database.

5). After that, start VembuNetworkBackup and resume/schedule the backups.

If the problem still exists, please send the result of last query (query mentioned in point iii), which will help us to give the suitable solution.

edit flag offensive delete link more
0

answered 2017-04-28 08:20:21 -0500

Hi,

Reported issue occurs if the "Next schedule time" is not updated properly in the database.We request you to edit and save the backup job to update 'next schedule time' automatically.

Please follow the below steps to resolve the issue.

  1. Click on Backup ---> List of Backups.
  2. Click on "Edit" next to the backup which has incorrect/old time updated.
  3. Click 'Next' till the last step and save the configuration as before.
  4. Once configuration is saved, please click on "Run Now" icon and wait for the backup job to complete.
  5. Now check the "Next Scheduled time". It should be updated properly.
edit flag offensive delete link more

Comments

No luck with the steps mentioned. schedule is listed as it was. Do i have delete and recreate the job?

abhis ( 2017-05-02 04:58:23 -0500 )edit
Login/Register to Answer

Question Tools

Follow
1 follower

Stats

Asked: 2017-04-28 07:17:19 -0500

Seen: 133 times

Last updated: May 02

Copyright © Vembu Technologies 2017. All Rights Reserved.