Remove Drive Letter on Recovery Partition

When adding an image backup, Vembu states that a drive letter should be added to the recovery partition on the disk. This was been added as Z:\ on the server.

I have removed Vembu from the server, but the recovery partition is still showing as the Z:\ drive, and I want to remove the drive letter from it so it is no longer showing in "This PC".

I've checked in Disk Management, but according to that there isn't a Z:\ assigned to a partition.

How can I remove the Z:\ drive from being assigned?

Thanks in advance.

image description

edit retag flag offensive close merge delete